GL868-DUAL SSL error during handshake

  • Hello,
    I am using Telit GL868-DUAL module with Firmware version 10.00.188
    I am trying to establish connection to the server using SSL. I have followed "Telit_SSL-TLS_User_Guide_r14" document and got the Root CA certificate but module is showing SSL error during handshake. I've attached the AT command log for the same and also the certificate.
    I've read threads having similar issue here and tried setting AT#CPUMODE=4 but the same error is reported.
    Also, as from the exported certificate, signature algorithm is sha1RSA.
    If I use no authentication, the connection is successful and I'm able to upload data to server.


    Also, the root certificate exported from browser contains CRLF after each line and the "Telit_SSL-TLS_User_Guide_r14" says there must be only LF after each line. So I've removed CR from exported certificate, changed number of bytes accordingly and put that into module NVM. Is this correct?


    One more thing, I have another module with different manufacturer and using same root certificate the communication(using no authentication, only server authentication and both server-client authentication) was successful. So I think I've got the right root certificate.


    I am new to SSL. Am I missing something while configuring module? Please help me fix the issue.
    Thank you in advance.

  • Hello,


    first you should update your Firmware, this will fix some errors and you will have a base to get better support.
    Newest Version is 10.01.151


    Please get in contact with your distributor for Firmwarefiles.


    Regards,


    Hüseyin

  • Hello Hüseyin,

    Distributor provided me development board having firmware version 16.01.153 and SSL worked perfectly in all three modes.

    Also, I downloaded the certificates as it is in the module i.e. without removing CR and not as stated in the "Telit_SSL-TLS_User_Guide_r14".

    Thank you for your help.