GL865 RTC Gaining time

  • Type of module? A: GL865-Quad
    Firmware version? A: 10.01.140




    I have a strange behaviour which has been advised by a customer.



    Using GL865-Quad the RTC is gaining time by several seconds (or 10s seconds) per hour. We have an alarm set which over a few days is therefore triggering at the wrong time.
    We have not noticed this before because most of our units auto-set the time using NITZ, so any error is corrected.
    This customer is using EE which does not seem to support automatic time setting.



    I have tried this on a couple of units and they all behave the same.
    Is this a known problem or is there something I have missed?
    I thought perhaps it was CPUMODE=3 that was the problem but it makes no difference using CPUMODE=0.
    This time error even occurs with no script running and SIM card removed.



    If this problem cannot be identified, is there a simple way to use HTTP commands to get the internet time and I can then set the clock.

  • Apologies for delay i reporting back.


    Telit technical support identified the problem as the over-voltage I was applying to the RTC supply pin. I have now corrected that hardware mistake and the time-keeping seems to be functioning correctly now. My error was to assume the RTC voltage was 3v (=coin cell) but in fact it is a max of 2.14v !


    Problem is now solved thank you.


    Thread may be closed