hardware flowcontrol

  • I can't send At commands in hardware flowcontrol mode.


    I tried some firmware of GM862-GPS, but I couldn't solve it. and I am having some problems that I think because of this.


    when I set flowcontrol NONE, I can send AT commands but it doesn't work for python script upload operation etc.


    about 1 year ago, I did lots of operations with module, but now I couldn't execute my python script in module.


    could you help me what I did wrong?

  • sir, I use EZ-10. [ GM862-GPS ]
    I checked my RS 232 cable. nothing changed. I can upload my script using hyperterminal. enable and then execute it. it seems working in module, because it doesn't take At command after I enter AT#execscr command.


    I tried simple code as following



    I compile it first and send .pyo file to module. I do all of these on flowcontrol NONE.
    nothing appears on my terminal screen. I thought it s something about settings or firmware, but I couldn't figure it out yet.


    everything works on command mode.I connected my server using GPRS connection.


    and I tried these operations on XP and Win 7.in both cases, I couldn't send At commands on Hardware Flowcontrol.

  • Quote

    sir, I use third party terminal. [ GM862-GPS ]


    Than you should ask for help there.


    After upload check if it's uploaded with AT#LSCRIPT<cr>
    than set AT#ESCRIPT="filename"<cr>
    and now start with AT#EXECSCR<cr>


    By the way, check your code, result is int => SER.send(str(result)+'\n')

  • ok, I will do that but I just want to ask one more question. simple one, I should be able to send AT commands in flowcontrol Hardware, right?


    and sorry for bothering.