MIME attachments

  • Please see code attached as promised. The Telit replies are in brackets ie (OK).

    I have send emails ok using EMAILD with exactly the same SMTP login sequence.

    ‘ Setup

    AT+CGDCONT= 1,"IP","orangeinternet","",0,0

    ‘ SMTP login
    AT#ESMTP= "smtp.orange.net"


    AT#EPASSW= "xxxxx"

    AT#EADDR= xxxxx@orange.net


    ‘ Activate

    ‘ Send an email
    AT#SMTPCL= "xxxx@xxxx.com","Text test",0

    (This is the code to send the message body, but is not used as I stop program execution when I get the above error.)

    ‘ Send a text string via the serial port
    command = "Hello from Telit Module" 'some text
    send_command() ‘ send text plus a <CR>

    ‘ Send ctrl Z to terminate
    command = Chr(26) 'ascii ctrl z character
    send_command() ‘ctrl Z plus <CR>

  • Wilhelm,

    Thanks for confirming your SMPTCL function works ok - that is very helpful.

    I have suspected that possibly the problem is with my ISP email server (British Telecom).

    Last night I sent a MIME email and attachment from my file server to my BT email account and it functioned perfectly, so the problem does not seem to be with my ISP.

    So I am currently stuck.

    Do you have any further ideas or suggestions.

    Many thanks


  • Quote

    Last night I sent a MIME email and attachment from my file server to my BT email account and it functioned perfectly

    With the commands do you posted before?

  • No, what I meant was that if your system works ok, it must be something to do with my setup. I wanted to double check that my ISP could process MIME attachments ok.

    So I wrote a PHP script using a File Server I own to send a MIME jpg image attachment to my email account and it worked fine - so the problem cant be with my ISP.

    I now have noticed that the error message I get when I invoke SMTPCL is immediate. It feels like its not a connection problem to the SMTP server, but something is not happy within the Telit setup, or the command is somehow not available.

  • Wilhelm,

    I just wanted to check the situation on this thread.

    I have been working on my system for about 3 months and I wont give up, but I appreciate there is a limit to what you can do in this forum and believe me, you have been fantastic.

    Do you have any ideas on how I can solve this? Is there a Tech Support group I could visit? I dont mind going to Europe.

    I would have a laptop, a Telit Quad and a power supply - thats it.


  • I am sorry, I don't have a Tech Support Group which you could visit and unfortunately I have no idea for your problem. I tried again and again to reconstruct it, with no success.