Can't connect to internet

  • Q: Type of module? A: TER-GX300S
    Q: Firmware version? A:
    Q: Type of starter kit you have?
    (S1, S1B, S2, S3, S4, EVK1, EVK2, none, other)


    Or at#gprs=1



    Although if I use atd*99***1#



    Then I can’t write anything. And after a while it disconnects



    I know that I get this CONNECT while it is waiting for all the authentication protocols to be typed in. but with the easy GPRS commands I am currently getting “ERROR +CME: service not supported”

    I tried the SIM in my mobile NOKIA N79 and I was successful in connecting to internet using GPRS from my ISP (etisalat).

  • the GPRS commands that i used are:


    I am successful in sending voice calls and sms. but when i write for example

    the modem just hangs up. i never get "CONNECT" on the "telitest" program and furthermore it doesn't accept any more commands. therefore, i then need to restart my modem.

    i tried "RSTERM" and got "CONNECT" but on that also i was unable to write anything after that on the command window. This happens for any command that has a web address or ip address for that site (etisalat doesn't allow calling websites by IP addresses). for example:
    (not to able to write anymore on the command window after connecting)

    Recently, the modem has started giving me "ERROR" when i try to connect to internet. i checked the SIM card (subsribed to post-paid service of etisalat) by putting it in my mobile NOKIA N79 and i was able to connect to internet. i am still able to send sms and make voice calls through the modem.

    i got CONNECT as mentioned earlier when i write:

    but then i cannot write anymore. for:
    AT#SGACT=1,1 or

    i get "ERROR" response.

  • try this and post me the result please:

    wait for OK

    in case you must send user and password (ask your provider whether it's needed)
    AT#USERID="your ID"<cr>
    wait for OK
    AT#PASSW="your PASSW"<cr>
    wait for OK

    AT#SGACT = 1,1<cr>
    wait for a valid IP

    here you should get a CONNECT

  • it started working again. despite, i haven't changed anything.

    anyways, it's good that it started working. but still, i cannot write anything on "rsterm" after i get CONNECT i.e. after writing

    AT#sd=1,0,80,"",0 <cr>

    similarly for the GPRS e-mail.

    also, can you tell me how to write "CTRL-Z" on rsterm if i try to use smtp e-mail. if i write "CTRL-Z" or "<CTRL-Z>" or press CTRL+Z nothing happens and after a while i get error.

    my at command code for SMTP e-mailing is:

    AT#EPASSW="my password"

    > hi

    (after a while)

    or if i try

    (now i can't write anything)

    looking forward for your reply

  • CRTL+Z means press key CTRL + key Z.

    For the email function you must check if your provider the needed ports for email or is just port 80 open. That is mostly the reason why this commands don't work.

  • thanks for clearing the confusion about typing CTRL-Z.

    i have attached a jpeg of the session in which i tried to send e-mail. after "CONNECT" response i am unable to write anything on the command window. i wrote "HELO" by using the button in rsterm.

    can you kindly tell me how can i continue writing commands as listed in the easy GPRS guide for this purpose. thanks

  • i finally was able to send e-mail to my e-mail account. after i got "connect" on rsterm, i just continued typing though i was not able to see what i have typed and it worked.

    also, gmail and hotmail requires some TLS negotiations which i don't know how to do. (it'll be great if you can provide info on that in the same way as provided for the SMTP in the GPRS guide as i found some info on the internet but it requires using a programming language).

    lastly, can you tell me how to attach a simple .txt file using these AT commands and sending it via e-mail as i saw "attach current image" checkbox but don't know what it do.

    Thanks for your cooperation.

  • you should use RSTerm section => Telit Email => semail to send your mail.
    Normally it should work.
    NOTE: start your module first and don't send any other commands before start with sending email.

  • i tried the RSterm=> telit email => semail to send the e-mail through hotmail or gmail but still it gives me ERROR as you can see in session1a.jpg while with the yahoo account it works as i told earlier (see session 1b.jpg).

    also, can you tell me how to attach a simple .txt file using these AT commands and send it via e-mail as i saw "attach current image" checkbox but don't know what it do.


  • dear wilhelim,

    thanks for bearing with me. i wanted to ask you, why exactly you are asking me to do this?

    i can now send e-mail through my yahoo account. is this for testing servers like hotmail or gmail which require TLS authentication?


    is this how i can add attachments to my e-mail? i read on a webpage that for attachments you need to open the file, convert its contents to base64 encoding, then write some html code for identifying that this e-mail has attachments also, use boundaries in the text to specify part of the e-mail which is an attachment and then you can send an attachment. here is the link:…p?t=418377&highlight=smtp

    i just wanted to know if i can use SEMAIL or any # command that do this as i saw "attach current image" option with SEMAIL. in the mean while i'll try to do this.


  • Quote

    i wanted to ask you, why exactly you are asking me to do this

    You told me the email function don't work. To get an imagine what happen there I ask you to this.

    Ok, if it work's now I suppose you first question is answered.


    "attach current image"

    This option is an old one and works with GM862 only. Has nothing to do with an attached file. For this you should do as described in your last post.