You are not logged in.

Dear visitor, welcome to Round Solutions M2M and wireless Support Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


Thursday, July 27th 2006, 6:09pm

Telit Python1.5.2+ Ver.3 freezes


I been doing some development of scripts using the Pythonwin interface. It worked fine for a couple of days, and now suddenly pythonwin won`t allow me to run the script thought the debugger. Either it freezes or gives me various errors. At times pythonwin doesn`t even open properly.

Has anyone experienced anything like this ? Any solution or alternate dev tool.
(I tried reinstalling manytimes, even manually deleted each installed file.. still no change.) I`m looking for a option without reinstalling my PC :(

Any help is much appreciated.


Friday, July 28th 2006, 9:41am

Telit Python1.5.2+ Ver.3 freezes

Python has known bug with debugger, sometime the use of debug creates thousands of toolbars inside the register and pythonwin application stucks or becomes very slowly, so to fix that you have to do following steps:

1-uninstall Python
2-from command line, execute regedit command and delete whole Python 1.5 directory located in HKEY_CURRENT_USER\\SOFTWARE
3-reinstalling python
4-before running python, go to file "" located in C:\\Python\\Pythonwin\\pywin\\framework
and comment out the line self.SaveBarState(ToolbarDefault)
(i.e #self.SaveBarState(ToolbarDefault) ), in fact this command line generates the toolbars that cause the above python`s bug.

I fixed my problem by this way, I hope it will help you :-)

- Edited by ivan1979 28.07.2006, 09:43 -


Friday, July 28th 2006, 11:11am

Telit Python1.5.2+ Ver.3 freezes

HI I had the same problem but did not know how to fix it. I reinstalled but did not do the regedit so it would not work.

What I did was to use the latest python 2.5 with the relevant win32all. You have to copy MOD. MDM etc across to a local directory. Everything seems to work fine I also use eltima serial port monitor to keep an eye on the commands going back and forth. This has allowed me to debug my scripts on the 862 gps.



Monday, July 31st 2006, 1:27pm

Telit Python1.5.2+ Ver.3 freezes


thanks guys, I`ll try these solutions out. I`ll first try Ivan`s solution, as that doesn`t involve installing another version of Python. Will let you know the result.

Thanks again


Monday, July 31st 2006, 2:01pm

Telit Python1.5.2+ Ver.3 freezes

Hi Ivan,

I think you gave the solution, spot on!!! It worked fine. I`ll use it a few days an post a coment if I see anything fishy happening.,. thanks again

Rate this thread