You are not logged in.


Thursday, June 2nd 2016, 2:33pm

GL865 RTC Gaining time

Type of module? A: GL865-Quad
Firmware version? A: 10.01.140

I have a strange behaviour which has been advised by a customer.

Using GL865-Quad the RTC is gaining time by several seconds (or 10s seconds) per hour. We have an alarm set which over a few days is therefore triggering at the wrong time.
We have not noticed this before because most of our units auto-set the time using NITZ, so any error is corrected.
This customer is using EE which does not seem to support automatic time setting.

I have tried this on a couple of units and they all behave the same.
Is this a known problem or is there something I have missed?
I thought perhaps it was CPUMODE=3 that was the problem but it makes no difference using CPUMODE=0.
This time error even occurs with no script running and SIM card removed.

If this problem cannot be identified, is there a simple way to use HTTP commands to get the internet time and I can then set the clock.

This post has been edited 3 times, last edit by "DocP" (Jun 2nd 2016, 6:42pm)


Friday, June 3rd 2016, 8:43am

Hi DocP,

I let check this issue from our support team and will post reply here.




Tuesday, September 13th 2016, 10:23am

Apologies for delay i reporting back.

Telit technical support identified the problem as the over-voltage I was applying to the RTC supply pin. I have now corrected that hardware mistake and the time-keeping seems to be functioning correctly now. My error was to assume the RTC voltage was 3v (=coin cell) but in fact it is a max of 2.14v !

Problem is now solved thank you.

Thread may be closed


Tuesday, September 13th 2016, 3:15pm

Thank you for feedback.

Tread is closed.


Rate this thread