You are not logged in.




Tuesday, May 10th 2011, 2:18pm

Problems getting started with Bluetooth starter kit

Q: Type of module? A: KC22
Q: Firmware version? A: Dont know (as delivered)
Q: Type of starter kit you have? S3
(S1, S1B, S2, S3, S4, EVK1, EVK2, none, other)

Dear Sir or Madame,

I am trying to get started with the STK-RS-Blue-KC22 Starter Kit which i have ordered from Round Solutions. The basic board is the RS-EB-S3, the adapter board is the bluetooth board with a KC22. Following the getting started guides from your website the board is not responding as described in your guide (…5.06.JUN.01.pdf) on page 8 after an initial connection per hyperterminal. Actually, nothing is shown on the console at all. To set up the Kit for hyperterminal access I have done the following steps in chronological order:

1. Plug serial cable in PC com port and x100
2. Power on the board (LED10 going on)
3. Power on the PC
4. Connect to the according COM port and settings as described on pages 5-7 in your KC_GettingStartedGuide

I have tried to turn the board off and on after and before connecting with Hyperterminal.
I have also tried to connect to the board over bluetooth with a usb-to-serial adapter with the same results.

During the whole process only LED10 was on (excluding the time when the board wasnt connected to power) while every other LEDs were off. No LED was blinking at no time.

I have included an image of the current state of the board so you can check for wrong configurations.

The package i recieved from Roundsolutions also contain an USB to UART Bridge adapter but i havent found any drivers for it on your website.

Yours sincerely,

Malte Menning
Menning has attached the following image:
  • S3_KC22.jpg


Tuesday, May 10th 2011, 3:26pm

RE: Problems getting started with Bluetooth starter kit

I must clarify and will come back to you a.s.a.p


Tuesday, May 17th 2011, 10:52am

RE: Problems getting started with Bluetooth starter kit

Have you closed the bridges (6x) on the back site from the adapter board?




Tuesday, May 17th 2011, 9:02pm

RE: Problems getting started with Bluetooth starter kit

No. At the moment there is only one solder bridge for power supply. I have checked several pins of the kc21 against the connections of the bridges for continuities. It seems that as you suspected the unconnected bridges are the reason for the malfunction.
I havent found any schematics describing that part of the adapter board on your website. Where to get it?
Considering all the bridges besides the one for power supply still not closed could it still be possible to connect to the kc21 with the usb bluetooth adapter which came with the starter kit?

On another note, the starter kit I recieved from Roundsolutions included only the RS-EB-S3 basis board and one adapter board which you can see in the image i added in my previous post. How do you attach the kc22 to that board? Am i possibly missing another adapter board?

This post has been edited 1 times, last edit by "Menning" (May 17th 2011, 9:08pm)


Thursday, May 19th 2011, 10:53am

RE: Problems getting started with Bluetooth starter kit

lets just look why your board does'nt work.
Is the jumper J11 on the S3 closed?




Thursday, May 19th 2011, 1:20pm

RE: Problems getting started with Bluetooth starter kit

Jumper j11 is closed. You can validate that by having a look on the image I have attached in my first post which shows the current state of the board.
If as you have said 6 bridges need to be closed on the backside of the adapter board then this is probably the reason why the board doesnt work (i.e. unable to get a connection to the kc21). At the moment only 1 bridge is closed (The one which is responsible for the power supply of the kc21). Even though I have a good guess which bridges need to be closed after looking at the backside of the adapter board I would still like to see some scematics for validation. Where to get them?

Please, also answer the questions I asked in my previous or forward them to appropreciate department of your service team if they arent within your scope.


Thursday, May 19th 2011, 1:40pm

RE: Problems getting started with Bluetooth starter kit

To clarify you will get an email soon.
Thank you for understanding.


Monday, May 23rd 2011, 11:57am

RE: Problems getting started with Bluetooth starter kit

I made some more test. Now it works.
After switch on the module you must reset it two or tree times than it works
(all bridges on the back MUST be closed).
I used X100 with 115200

Rate this thread