You are not logged in.


Monday, March 5th 2007, 8:58am

ftp fileput escape sequence

Q: Type of module? A:GM862-GPS
Q: Firmware version? A: 07.02.401
Q: Type of starter kit you have? A: S2, custom HW


is there another way to tell the module that the ftp fileput data transfer
is finished than sending the esacpe sequence ?

the problem is that it's possible that a binary datafile can contain the
escape sequence - that would result in an incomplete file on the ftp-server.

the standard method for this problem is to escape the escape-sequence...
but that would mean that the end application has to process the file on the
ftp server and remove the escaped- sequences before it can use the file.
since the end-application shouldn't care about the origin of the file (GSM
module or a standard ftp client) I'm not very happy with this workaround.

maybe in other words: is it possible to put a file on a ftp server which contains +++ (the escape sequence) ?

thanks for your hints,

Cosmin Buhu



Monday, March 5th 2007, 5:13pm

Yes, because the sequence must be correctly guarded with silence time (1 second by default) in order to terminate transfer.


Monday, March 5th 2007, 5:34pm

I tought of this way but I was not 100% sure about the behaviour of the
escaping in ftp mode. (because I read the not for SKIPESC where is
mentioned that this settings works different for ftp commands)

following up I have two questions left:

1.)is the E2ESC parameter is also used for ftp operations ?
2.)just to be sure - to detect a escape sequence as valid the
communication has to be idle for at least tguard before the sequence is
sent, right?


Cosmin Buhu



Tuesday, March 6th 2007, 7:17am

1) yes
2) before and after


Tuesday, March 6th 2007, 8:58am

ok, great - that will work.

thanks for your quick help!

matthias fend

Rate this thread